Xerox Workcentre 7775 Printing Streaks and Lines

Discussion in 'Xerox Color Laser Printers & Color Copiers' started by Dave Paul, May 31, 2018.

  1. Dave Paul

    Dave Paul New Member

    Joined:
    May 2018
    Messages:
    3
    Location:
    Calgary, Canada
    I Have a Workcentre 7775 that has some print quality issues and I'd appreciate any advice going on what the cause is likely to be. Attached is a copy of the Drum Test. I switched the Cyan with Yellow drum and the lines are yellow after printing. I also see the lines pattern on the transfer belt. I would appreciate some help on this issue. I replace the Magenta drum, it didn't resolve the problem. still printing streaks
     

    Attached Files:

  2. OkiTech

    OkiTech Senior Member

    Joined:
    Jan 2008
    Messages:
    708
    Location:
    NEW JERSEY
    You can measure the distance between flaws - they would be equal to cirumference of the roller that is bad. Drums are much larger to give you repeat flaws this often. Is there a ITB cleaning device, like a blade? on some machines it is user replaceable on some it is not. How does your fuser looks like? I have a feeling that it may look like crap. Also it can be something stuck on the Magnetic roller of Magenta Developer Unit and leave impression this often. I am not a Xerox tech, Phaser 7800 is the biggest Xerox I would opt out to work on but out of general knowledge.... and since nobody else wants to chip in...
     
  3. OkiTech

    OkiTech Senior Member

    Joined:
    Jan 2008
    Messages:
    708
    Location:
    NEW JERSEY
    Have you been printing a lot of labels by any chance?
     
  4. Dave Paul

    Dave Paul New Member

    Joined:
    May 2018
    Messages:
    3
    Location:
    Calgary, Canada
    Thanks for the response. I figured it out. The Roller on the Magenta Drum went bad.
     
  5. Dave Paul

    Dave Paul New Member

    Joined:
    May 2018
    Messages:
    3
    Location:
    Calgary, Canada
    Thanks for the response. The problem was bad roller and the Magenta Drum
     

  6. OkiTech

    OkiTech Senior Member

    Joined:
    Jan 2008
    Messages:
    708
    Location:
    NEW JERSEY
    I would suspect that this could be bad PCR (primary charge roller) on the drum, certcertainly looks like it but you said that drum unit is brand new....
     
Loading...

Share This Page