Vacuums don't stop after imaging

Discussion in 'DI Presses' started by maverick1971, Jun 29, 2019.

  1. maverick1971

    maverick1971 Senior Member

    Joined:
    Jul 2011
    Messages:
    137
    Location:
    South Africa
    HI EVERYONE,

    We are experiencing a problem on our QMDI PLUS:

    VACUUMS DO NOT STOP AFTER IMAGING CYCLE COMPLETES
    Vacuums only stop if we switch the press OFF and restart.

    Can anyone help with advice on this. What could be the cause?
    How do we fix this issue?

    Please help.

    Regards

    Shawn
     
  2. CHOCK

    CHOCK Senior Member

    Joined:
    Dec 2016
    Messages:
    1,279
    Location:
    Managua,Nicaragua
    Test the air relief valve (clean it very well) and see if the system is working +sensor.
     
  3. maverick1971

    maverick1971 Senior Member

    Joined:
    Jul 2011
    Messages:
    137
    Location:
    South Africa
    Hi Chock,

    Please can you tell me where to locate the air relief valve that you mentioned?

    Regards Shawn
     
  4. CHOCK

    CHOCK Senior Member

    Joined:
    Dec 2016
    Messages:
    1,279
    Location:
    Managua,Nicaragua
    Look in your operator manual( section maintenance and clean it)
     

  5. maverick1971

    maverick1971 Senior Member

    Joined:
    Jul 2011
    Messages:
    137
    Location:
    South Africa
    Hi Chock

    Many Thanks

    I will look it up!

    Regards

    Shawn
     
Loading...
Similar Threads
  1. impressed
    Replies:
    20
    Views:
    5,936