Ryobi 525 hxl problem, please help!

Discussion in 'Ryobi Printing Presses' started by Bornaktm, Mar 20, 2018.

?

Ryobi 525 hxl problem

  1. ryobi

    0 vote(s)
    0.0%
  2. offset

    0 vote(s)
    0.0%
  1. Bornaktm

    Bornaktm New Member

    Joined:
    Mar 2018
    Messages:
    2
    Location:
    Austria
    Hi,
    I have Ryobi 525 hxl, problem is that machine can not be started and monitor shows me this. a5e4e8a8-0a7e-4925-802d-5bac6439ea1e.jpg
    Any body who has similar problems?Any solution? It would be great if someone could really help.
    Regards
     
    Last edited: Mar 21, 2018
  2. CHOCK

    CHOCK Senior Member

    Joined:
    Dec 2016
    Messages:
    1,736
    Location:
    Managua,Nicaragua
    Hi
    Good day
    Look for 1) flat or Ribbon or Flex Cable loose between Screen and CPU board and clean Edge connector with Electronic Spray Contacts.
    2) Measure Lithium Battery if is under 3.3 Vdc.
     
  3. Bornaktm

    Bornaktm New Member

    Joined:
    Mar 2018
    Messages:
    2
    Location:
    Austria
    Thank you for your reply.
    We've all checked the cables and we've put them together again.
    Battery is new 3.6 vdc.
    The machine still can not be started.
    Is there any more possibility?
    We tried everything and still nothing happens and we still don't know what the problem is.
     

  4. CHOCK

    CHOCK Senior Member

    Joined:
    Dec 2016
    Messages:
    1,736
    Location:
    Managua,Nicaragua
    Please put Attention to this:
    CPU board +ALL boards C lean Edge connectors withElectronic Spray Contacts.
    this is the cause of Most terrific problem in Electronic.
     
Loading...