doubling on Ryobi 3304H

Discussion in 'Ryobi Printing Presses' started by ABerg3860, Mar 30, 2020.

  1. ABerg3860

    ABerg3860 Member

    Joined:
    May 2013
    Messages:
    33
    Location:
    Northwest Florida, USA
    Today as I set the press, getting it in registration and balancing out the ink, I did not have trouble with a double image until I started printing for real. The most puzzling thing is that it is only on the tail end of the sheet on the operator's side. As I said, in all my set ups, this was not an issue. I have checked and double checked the pressure, both overall and parallel, of the infeed roller just before the first set of grippers. I have lubed all the gripper bars in the press. I thought I might have too much impression pressure, backed that off till it did not print well, then added a little back till I got proper image back. Someone suggested I might need to change the grippers. How can you tell if they are bad? They seem to hold a strip of paper when inserted one at a time.
    Any help would be appreciated.
     
  2. Warren Peace

    Warren Peace Member

    Joined:
    Feb 2019
    Messages:
    40
    Location:
    Houston, TX
    Did you get this issue resolved? What is the condition of the gripper edge of the sheet after printing? A gripper could be opening late.
     
  3. ABerg3860

    ABerg3860 Member

    Joined:
    May 2013
    Messages:
    33
    Location:
    Northwest Florida, USA
    Yes we did. We replaced the grippers and stop fingers on the first infeed cylinder. The rubber was all gone from the grippers and there were small grooves starting to appear on the stop fingers. After installation I also had to readjust the pressure of the infeed rollers to keep them from pushing the paper too far in, which did cause some pretty bad nicking on the paper.
     
Loading...