3304HA with stream feeder stuck on impression HELP!

Discussion in 'Ryobi Printing Presses' started by Moonprinting, Feb 6, 2014.

  1. Moonprinting

    Moonprinting Member

    Joined:
    Mar 2013
    Messages:
    18
    Location:
    Michigan
    I have a 3304 ha or presstek 4995 with the stream feeder. My problem is that the first two heads seem to jump early or stay on impression while the press is doing it's thing preparing to run sheets. While it's dampening the plates and inking up the first two heads seem to be already on impression. This causes the impression cylinder to ink up and transfer the image onto the back of the sheets until it wears off. I've cleaned all the sensors and am really puzzled. My operator instantly goes into call service or sales to buy a new machine. ANY IDEAS? Any help would be appreciated. thanks
     
  2. ziggy33

    ziggy33 Senior Member

    Joined:
    Jul 2010
    Messages:
    434
    Location:
    Rice Lake WI
    sounds like your sensors need to be adjusted (on the electrical board), or your impression latches are allowing the first two heads to go down, either way your gonna want a service tech to make that adjustment or you could really screw things up.
     
  3. Moonprinting

    Moonprinting Member

    Joined:
    Mar 2013
    Messages:
    18
    Location:
    Michigan
    Thank you for your input. I kinda figured it would involve a service call, but there was always hope that it was a quick, cheap & easy fix.
     
Loading...