Static PR

Discussion in 'Xerox iGen3, iGen4, & iGen5 Digital Presses' started by Neess, Nov 6, 2019.

  1. Neess

    Neess Senior Member

    Joined:
    May 2011
    Messages:
    164
    Location:
    Aarhus, Denmark
    Hello.

    On our iGen150 press we have a lot of issues with static PR belts, they run about 4-5k impressions and then the PR Drive velocity error starts to pop up. Meaning we use alot of PR belts lately.

    Any advice?
     
  2. Milo Wilson

    Milo Wilson Senior Member

    Joined:
    Dec 2007
    Messages:
    423
    Location:
    Arkansas
    Make sure to clean both pr drive rolls at the bottom of the pr assy thoroughly with a rag and 409 everytime you remove the pr belt for any reason.
     
  3. peels

    peels tree killer :)

    Joined:
    Dec 2010
    Messages:
    1,080
    Location:
    southeast iowa, usa
    add to that a CLEAN rag. I use alcohol.

    I once went through a whole day with this error, thinking it was a bad belt... turns out I was just cleaning it using a dirty greasy rag... causing slippage.
     
  4. Milo Wilson

    Milo Wilson Senior Member

    Joined:
    Dec 2007
    Messages:
    423
    Location:
    Arkansas
    I only use 409 because it won't dry out the rubber coating.
     
  5. Neess

    Neess Senior Member

    Joined:
    May 2011
    Messages:
    164
    Location:
    Aarhus, Denmark
    We always do a good clean with the right cleaning solution(not the soapy one)
    The issue seems to have been the tourqeroller slipping and causing static buildup.
     
  6. Milo Wilson

    Milo Wilson Senior Member

    Joined:
    Dec 2007
    Messages:
    423
    Location:
    Arkansas
    I usually clean both rollers until they're nice and dark black. That takes care of it 95 % of the time.
     
  7. Neess

    Neess Senior Member

    Joined:
    May 2011
    Messages:
    164
    Location:
    Aarhus, Denmark
    I have been changing PR belts on 6 different iGens in the last 10 years, never had a PR belt going so static it nearly cant be tanke off without cutting it after only 3.000 impressions.
     

  8. SMAKCruiser

    SMAKCruiser Member

    Joined:
    May 2012
    Messages:
    47
    Location:
    USA
    You need to verify that the static eliminator power supply is working on the PR Module.
     
Loading...