SM74-4 delivery pile can't go up

Discussion in 'Heidelberg Printing Presses' started by Bert Hews, Mar 27, 2018.

  1. Bert Hews

    Bert Hews Member

    Joined:
    Sep 2017
    Messages:
    11
    Location:
    Fiji
    Hi all, I have a delivery pile for SM74-4 that won't go up. It can go downwards but not upwards. Need advice on how to get it back to it's normal operation.
     
  2. turbotom1052

    turbotom1052 Senior Member

    Joined:
    Oct 2008
    Messages:
    580
    Location:
    Vermont
    you can begin by making sure that your rear jogger has not engaged the limit switch. Are you certain that the delivery pile chain has not lost its proper engagement with the sprockets? There should also be limit switches just above ground level that could be all gunked up with powder and such. These lower limit switches will be engaged with little half moon shaped parts on the delivery pile chain.
     
  3. Abhi

    Abhi Member

    Joined:
    Mar 2017
    Messages:
    84
    Location:
    Nepal
    Check the limit switches mate. Most of the times these are the culprits.
    You should also check for faulty relays in the electrical cabinet.
    If you don't have the proper schematic, then you would have to find the relay yourself.
     
  4. Bert Hews

    Bert Hews Member

    Joined:
    Sep 2017
    Messages:
    11
    Location:
    Fiji
    It was the pile drop sensor, the coin shaped sensor. It was faulty, new part has been installed. Thanks everyone for the advice.
     

  5. asem alsafady

    asem alsafady Member

    Joined:
    Mar 2016
    Messages:
    30
    Location:
    Amman Jordan
    Thanks for the feedback.
     
Loading...

Share This Page