Polar 115 E turn on but no image in display

Discussion in 'Cutters and Trimmers' started by oabrahim, May 3, 2022.

  1. oabrahim

    oabrahim Member

    Joined:
    Apr 2016
    Messages:
    29
    Location:
    Venezuela
    More details, We found the battery in CP2 discharged. It was replaced.
    The machine turn on, the backlight for the display turn on but no image appears.
    The KC2 is ok. It turns on and the red led is flashing slowly (1 Hz) but have no comunication with CP2.
    In the turn on process you can hear one beep, but the three beeps are not present to indicate the communication between KC2 and CP2.
    Neither the backgauge can be activated although the frequenz inverter is ready to job. (green led blinking).
    It seems like the communication between CP2 and others cards is not established, but maybe you can give more guides to fix the origin of this failure. it will be usefull.
    we wait any comment
    thank you in advance
     
  2. ashok kumar

    ashok kumar Senior Member

    Joined:
    Nov 2017
    Messages:
    150
    Location:
    india
    Hi
    Can you confirm how the people started and you change the battery.
     
  3. rspblake

    rspblake Member

    Joined:
    Dec 2013
    Messages:
    26
    Location:
    london
    I was working on a cp2 and kc2 yesterday evening.. I have access to a test rigs to try various panels , cps software and displays.
    Always looking for faulty polar cards to add to repair list if anyone got them gathering dust..
    We had a faulty kc2..now repaired but
    The display was still booting to a polar display and on to a program screen showing an brk 16 error
    The kc2 was showing power via the green led but no flashing 3rd led and tests 5vdc on the testing points. When booting I never got the single and final 3 bleeps to confirm complete data link.
    but I still got the screen…
    You have to remember the kc2 , cp2 and graphics although linked pickup there power supply from various points
    I believe your fault is graphics not kc2 or a cp2 problem as you are getting the single plus 3 bleep.
    Can you check under front of machine ps voltage pcb card, powered via a 45v from the Kap card.
    I had a screen faulty today with a blown c5 cap failed kap board.. but the other month lcd screen had failed and needed replacement.
     
  4. oabrahim

    oabrahim Member

    Joined:
    Apr 2016
    Messages:
    29
    Location:
    Venezuela
    Hello rspblake
    I will check your comments on machine.
    Thank you
     

  5. oabrahim

    oabrahim Member

    Joined:
    Apr 2016
    Messages:
    29
    Location:
    Venezuela
    Can you explain your question?
     
Loading...