ok once again my 78 ED is on a good one

Discussion in 'Cutters and Trimmers' started by jag, Jun 25, 2018.

  1. jag

    jag Member

    Joined:
    May 2013
    Messages:
    8
    Location:
    San Diego, California USA
    here is my issue we have been working ongoing on this cutter its been a love hate relation ship today while cutting I felt like the blade was struggling to cut like a loss of power I thought wow maybe my oil was low nope looks good I do here like a clicking sound not sure what is , it was working great for a good 7 hours then it started to act up this is what I did

    #1 changed the blade

    #2 Greased all the nipples

    # 3 Checked all the windows for oil all looked good half way mark

    #4 oiled the pullys that drive the belts

    #5 Changed the carbon on the clutches

    im heading out now but if anybody has any other ideas please help me out ..
     
  2. CHOCK

    CHOCK Senior Member

    Joined:
    Dec 2016
    Messages:
    1,175
    Location:
    Managua,Nicaragua
    Hi sir:
    Please do test the Hydraulic oil: 1) See if the Oil level is o.k IF NOT, please refill, and Bleeding very well the system
    otherwise, you must have the same problem.
    a) Bleed the Clamp
    b) cylinder clamp
    c) Max-Min Pressure
    d) Safety pressure
    e) Clean or replace the Oil filter for Hydraulic Pump
    f) See if there are Leaking inside from the Hydraulic Block, repair or replace.
    g)Measure with DMM the Voltage according with his Schematic Diagram Y27 +y27ain Hydraulic Solenoid and see if there are Stuck in shaft in the same solenoid problem mechanical,replace or repair.
    Let me know
    Blessing
    superchock@yandex.com
    cell+whatsApp:+505 88611441
     
  3. jag

    jag Member

    Joined:
    May 2013
    Messages:
    8
    Location:
    San Diego, California USA
    ok so here is deal took cover off to expose all belts and motors checked both belts and realized small belt has several cracks and when the pully moves on the cracked part it skips hence the loss of power for cutting hopefully this is the problem will keep you posted after replacing belt
     
  4. CHOCK

    CHOCK Senior Member

    Joined:
    Dec 2016
    Messages:
    1,175
    Location:
    Managua,Nicaragua
  5. jag

    jag Member

    Joined:
    May 2013
    Messages:
    8
    Location:
    San Diego, California USA
    that was my problem belt replaced and carbons tighten now back to working like new ...
     

  6. CHOCK

    CHOCK Senior Member

    Joined:
    Dec 2016
    Messages:
    1,175
    Location:
    Managua,Nicaragua

Share This Page