Horizon fc-20a trimmer

Discussion in 'Collator-Booklet Maker Systems' started by Eric.K, Mar 13, 2014.

  1. Eric.K

    Eric.K Member

    Joined:
    Aug 2013
    Messages:
    43
    Location:
    KENYA
    Hi guys, I have an issue with the Horizon FC-20A trimmer unit, the knife doesn't run on AUTO but when you use the manual button, its working well,all sensors are working, what would be the problem, anyone with an idea?
     
  2. eltitcho

    eltitcho Member

    Joined:
    Apr 2012
    Messages:
    9
    Location:
    Hereford
    is the booklet running straight through the back of of the trimmer or does it jam in there?
     
  3. Drifta

    Drifta New Member

    Joined:
    Mar 2015
    Messages:
    3
    Location:
    Sydney, australia
    I have had this problem before and repaired it by adjusting the torque and speed regulator which is inside the frame on the op side, if not that i can only think its a faulty sensor.
     

  4. hps2322

    hps2322 Member

    Joined:
    Jun 2010
    Messages:
    12
    Location:
    Irvine, CA
    Hello, I have developed a problem with my trimmer (FC-20A) as well. It will work for a while then the blade will stop, slightly past the cut and shut down the whole machine. I have been checking the sensors, connections, I have even removed the knife and it'll still stop. I did notice a lot of play (slack) in the chain. At rest the slack is at the top but then moves to the bottom. There's a bit of a thump when the motor starts until the chain is taught. I'm first off wondering is that slack in the chain normal and needed or has my chain stretched. Secondly if it is normal. what could be causing this issue. Any help would be greatly appreciated.
    Thank you - Hank
     
Loading...