copper wear and chrome pitting

Discussion in 'Komori Printing Presses' started by Jameybiz, Nov 1, 2011.

  1. Jameybiz

    Jameybiz Member

    Joined:
    Jan 2008
    Messages:
    7
    Location:
    Maine
    we have a ls40p press and the copper rollers are wearing down to a silver look. Also our chrome rollers are starting to get pits from underneath the chrome like the orginal metal wasnt treated well.. Komori said this is all normal wear.. Has anyone had this trouble and is it normal for the copper to wear away in 5 years?
    thanks
     
  2. timc

    timc Senior Member

    Joined:
    Aug 2009
    Messages:
    104
    Location:
    leicester
    the copper can wear depending on roller settings as for the chrome water sometimes gets under it and lifts parts of the chrome off Normally at the ends of the rollers
     
  3. Meny

    Meny Senior Member

    Joined:
    Apr 2008
    Messages:
    773
    Location:
    Israel
    Opinion

    In general , i think 5 years is way too short for this condition , but wonder if it has no local reason ??

    I know of copper rollers that hold 10+ years with no problem and Chrom rollers that stand for 15 years , but in some cases shorter - much shorter.
    I have asked myself why and what deffers one from the other , and yet no answer.
    I think that one reason could be a small electrice current running in the press building up the conditions for this ware , but never had the real chance to check it out.
    I have seen It before , but at this point i can only offer to recover to a high level (Komori do a good job) with a dedicated supplier to this task.
    good luck
     
  4. HPC

    HPC Senior Member

    Joined:
    Apr 2011
    Messages:
    125
    Location:
    Illinois
    I am not familiar with Komori, but 5 years seems a bit short for copper. There are a few ways you can cause your own problem. First off, even if you do a good wash up if you don't do a 3 step ink will begin to harden the rubber rollers that come in contact with copper. The hardened ink rollers will work on wearing out the copper. Last but not least, check the blade, on the washup tray if this is the copper roller that is failing
     
  5. henrym

    henrym Member

    Joined:
    Oct 2010
    Messages:
    10
    Location:
    schamburg Il USA
    I had this problem repeatedly on a web press, we had some success by having the roller re chromed completely end to end so the hard chrome was fully covering the journals. we also had some success having the same rollers re covered with stainless.
     
  6. spike

    spike Senior Member

    Joined:
    Apr 2011
    Messages:
    139
    Location:
    new york
    back in the day we would use a copperiseing soloution on the meatal rollers this helped keep them ink receptive
    where does your water for the fountain soloutin come from is there alot of minerals in it may be leading to premature wear
     
  7. FFR428

    FFR428 Senior Member

    Joined:
    Feb 2008
    Messages:
    432
    Location:
    CT
    I ran a 5C 20" Komori for years and several of the chrome water fountain rollers had the chrome finish crack and lift off the roller core. This does wonders for the water form roller. :( Press was a good 7 years old by then and 2 out of 5 units had the roller problem. Copper coating on ink rollers was fine with no excessive wear.
     
  8. glenn lamarche

    glenn lamarche Member

    Joined:
    Jun 2011
    Messages:
    43
    Location:
    Ontario Canada
    We had the same problem on our Ls29 6 Colour .We use a copperising solution once a month ,We also maintain our rollers well with febo every week and calcium fix every week. With this press its all about the water how clean it is and your mix We dump waters every week and mix fresh
     
  9. glenn lamarche

    glenn lamarche Member

    Joined:
    Jun 2011
    Messages:
    43
    Location:
    Ontario Canada
    sorry our press is 5 years old and copper was looking bad after 4 years
     
  10. FSA

    FSA Senior Member

    Joined:
    Jan 2011
    Messages:
    313
    Location:
    Winnipeg, Manitoba
    Glenn
    Do you run alcohol?
    fsa
     
  11. glenn lamarche

    glenn lamarche Member

    Joined:
    Jun 2011
    Messages:
    43
    Location:
    Ontario Canada
    No we do not we run two part system fuji emerald jr and sub
     
  12. Meny

    Meny Senior Member

    Joined:
    Apr 2008
    Messages:
    773
    Location:
    Israel
    Hi Guys

    I have the answer to the Chrome rollers going bad - simply contact me by e-mail or phone , as i do not wish to post it in the open , but do have a free solution for you.

    Meny
    +44-79-24232341
     
  13. NotAGooner

    NotAGooner Senior Member

    Joined:
    Dec 2007
    Messages:
    264
    Location:
    UK
    The whole idea of a forum such as this, is to SHARE information, surely, otherwise, what's the point?
     
  14. Meny

    Meny Senior Member

    Joined:
    Apr 2008
    Messages:
    773
    Location:
    Israel
    My friend

    Some information i can share , some not.
    I am willing to help but not allowed to post this in the open , so will have to do it in a quite way.
    I have no intention to run to politics not to ask any money for the info.... but can only share it (with every one) in a quite way.

    best regards
    #
    Meny
     
  15. greyhorse

    greyhorse Member

    Joined:
    Jul 2011
    Messages:
    36
    Location:
    Latvija
    chrome rollers in K29"

    There are cases where after 3 years is damaged chrome (EU location)

    www.greyhorse.lv
     
  16. petar

    petar Member

    Joined:
    Sep 2010
    Messages:
    25
    Location:
    Bulgaria
    Contact Komori and they will send you new rollers
     

  17. Kaoticor

    Kaoticor Senior Member

    Joined:
    Jul 2011
    Messages:
    56
    Location:
    New York
    Our copper rollers are showing signs of wear after 11 years.
     
Loading...