Chiller problem - qmdi classic

Discussion in 'DI Presses' started by maverick1971, Jul 15, 2016.

  1. maverick1971

    maverick1971 Senior Member

    Joined:
    Jul 2011
    Messages:
    138
    Location:
    South Africa
    Hi All,

    We have just brought our 2nd QMDI Classic online after resolving some minor issues. Unfortunately - after going into production today, we experienced some toning problems on units 3 & 4.

    We then noticed that the temperature of the press was at 29 degrees celcius.
    Technotrans is running continuously also. Temeprature control unit is set at 20 degrees. Water is at 3.5 bar when the press is running.

    Can anyone clarify if this is a WATER issue or maybe a GAS issue with the technotrans compressor? What temperature should the press be at ideally?

    Any feedback would be appreciated. Thanks & Regards
    Shawn
     
  2. maverick1971

    maverick1971 Senior Member

    Joined:
    Jul 2011
    Messages:
    138
    Location:
    South Africa
    Hi Again,
    West have found the problem with the chiller. The compressor has seized up internally and won't start up.
    Unfortunately -this means a NEW compressor unit has to be ordered and installed.

    Just thought I would update everyone on the status of the problem.

    Regards
    Shawn
     
  3. Paul Cavanaugh

    Paul Cavanaugh Senior Member

    Joined:
    Dec 2009
    Messages:
    628
    Location:
    Kennesaw, GA
    Thanks for letting us know you found the problem.
     
Loading...